Invoke operation 'CheckServerConnection' failed. The remote server returned an error: Not Found.

Jun 1, 2013 at 8:32 PM
Hi i setup correctly mysemanticsearch. But i have error below

Error screen

Any suggestions?

Thank you...
Jun 1, 2013 at 10:20 PM
Hi polen18,

First of all, thanks for your interest in MSS. I'm no longer working on this project, but I'll do my best to help you. Do you speak Spanish? If so, we can probably switch from English, if that's more convenient for you.

With regard to the error you're receiving from MSS: Can you connect to the SQL Server instance via SSMS? If so, is the RIA service up and running? You can check this by going to the following URL on your machine.


If that URL is not working in your environment, it may indicate that the RIA Service installation failed at some point.
Jun 1, 2013 at 10:26 PM
Thank you for fast replay... Sory i havent Spanish... my SSMS working. But i dont know RIA service up and running? Your url not working for me. Can you make any suggestions?

Thank you...
Jun 1, 2013 at 10:31 PM
Edited Jun 1, 2013 at 10:31 PM
Please check this thread, where I posted some possible solutions for problems when installing the RIA service.

The RIA service is a WCF service which is installed in IIS, along with MSS. Unless this service is up and running, MSS won't be able to connect to the SQL Server instance. You can see this in the documentation for this project.
Jun 1, 2013 at 10:39 PM
Thank you again... I know this thread and i checked it. You using TeamViewer? Can you connect my computer? I trying 2 day everythings...

Thank you for help...
Jun 1, 2013 at 10:41 PM
Edited Jun 1, 2013 at 10:43 PM
Sure, just send me your Team Viewer ID and Password, I can connect right now.
Jun 2, 2013 at 1:01 AM
It's OK... Thank you so much Daniel,

I upgrade my OS edition. My old OS editon Win7 Home Premium, i upgrade Win7 Ultimate edition. It's ok.

Thank you so much...
Jun 2, 2013 at 1:06 AM
Edited Jun 2, 2013 at 1:07 AM
You're welcome Zagor.

Just for the record: In IIS the Windows Authentication option in the Authorization section for the MSS website was not available. This was because W7 Home Premium Edition does not include it as part of the features. Once he upgraded to W7 Ultimate, the option was available amongst Windows features, which allowed us to install it in IIS, enable it (disabling the rest of the available options), and log in to MSS.

Enjoy it! Best regards,

Daniel Altamirano
Jun 2, 2013 at 9:22 AM
Yes now all is ok. Working.