Incomplete Install? No Desktop Shortcut

Jan 26, 2012 at 8:17 PM

It looks like setup completed successfully, but no desktop shortcut was created. I see the MySemantecSearch site in IIS Manager. Is there an install log file I can look at to start troubleshooting? What file does the shortcut point to? I am running Server 2008R2 and SQL Server 2012 RCO on the same machine.

Developer
Jan 27, 2012 at 12:10 PM
Edited Jan 27, 2012 at 12:13 PM

Hi Rekonn,

There's no install log file, but the most likely cause for that error is that Silverlight's not properly installed.

If you open the InstallApp.ps1 script inside the Setup\Tasks folder, you'll see that the sllauncher.exe executable is used to install the xap file, and also to create the desktop shortcut.

Please, check that the sllauncher.exe file is located either at Program Files\Microsoft Silverlight or at Program Files (x86)\Microsoft Silverlight.

If it's not located there, be sure to install Microsoft Silverlight's runtime.

Please, let us know if this solves your problem or if you need additional help.

Jan 27, 2012 at 4:04 PM

Thanks for the quick reply! Sllauncher.exe is in C:\Program Files (x86)\Microsoft Silverlight. The MySemanticSearch setup files are on the D: though, do they need to be on the same drive?

Jan 27, 2012 at 5:10 PM

Yup, that did it, did uninstall, moved setup folder to C:, then installed and it worked! Shortcut is now on the desktop. Now I just need to stop IE from blocking application content...

Developer
Jan 27, 2012 at 5:13 PM

Hi Rekonn,

Glad you were able to solve it! Let us know if you need any extra help.

Regards,
--
Daniel Altamirano

Jan 27, 2012 at 5:31 PM

I will need your help with one more thing actually. After entering instance name, I get an error:

Invoke operation 'CheckServerConnection' failed. [HttpWebRequest_WebException_RemoteServer]Arguments: NotFoundDebugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=4.0.60831.0&File=System.Windows.dll&Key=HttpWebRequest_WebException_RemoteServer

 

Btw, to stop IE from complaining when launching app, had to turn off Internet Explorer Enhanced Security Configuration, step below:

  1. Go to Server Manager
  2. Click the top item in the tree labeled "Server Manager"
  3. On the page that appears, go to "Security Information"
  4. Look for "Configure IE ESC" on the right and disable the feature
Jan 27, 2012 at 8:28 PM

Any chance you could let me know what settings you have in IIS under the MySemanticSearch site for Authentication and Connection Strings? Also, Advanced Settings for ASP.NET v4.0, whether Load User Profile should be set to True or False. Using fiddler2, I found out that it is an HTTP 401.2: Denied by server configuration error.

Developer
Feb 6, 2012 at 11:53 AM

Hi Rekonn,

By today's end of day, we'll provide you with the information you requested, and if that doesn't help, we'll be working during the week to help you solve this problem.

Regards,
---
Daniel Altamirano

Developer
Feb 7, 2012 at 12:51 PM

Hi Rekonn,

Here's the information you requested. Please, let us know if this helps solve your issue.

Authentication

SQL Connection String

ASP Advanced Settings

Feb 10, 2012 at 2:27 PM

Any luck on getting this error fix?  I am having the same issue and I am stuck at the enter instance name.

Invoke operation 'CheckServerConnection' failed. [HttpWebRequest_WebException_RemoteServer]Arguments: NotFoundDebugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=4.0.60831.0&File=System.Windows.dll&Key=HttpWebRequest_WebException_RemoteServer

-Joe

Developer
Feb 10, 2012 at 2:37 PM

Hi Joe,

Can you check this other discussion? In the last post, we provided more information to help troubleshoot this same error.

Please, let us know if anything there helps.

Regards,
---
Daniel Altamirano

Feb 10, 2012 at 2:48 PM

I check out that thread and verified all those steps were correct, but I still have the same issue.

Anything else I can try?

 

-Joe

Developer
Feb 10, 2012 at 2:57 PM

Can you browse this URL? It should work on the machine where MySemanticSearch was installed.

http://localhost:7777/MySemanticSearch/MySemanticSearch-Web-DataAccess-SqlServerManagement.svc

Let us know if that service is working.

Regards
---
Daniel Altamirano

Feb 10, 2012 at 3:08 PM

I get a blank page when I try to browse that URL.

Developer
Feb 10, 2012 at 3:45 PM

Then there's the problem. The service was not installed properly, or is not working because of something else.

Please, follow these steps:

  1. Go to Control Panel/Uninstall a Program.
  2. Uninstall My Semantic Search RIA Service.
  3. Go to C:\MySemanticSearch\Tasks, and run setup.exe with elevated privileges.
  4. In the Select Installation Address page, select MySemanticSearch for the Site, and ASP.NET v4.0 for the Application Pool.
  5. After installing it, double-click the My Semantic Search icon on the desktop to test the application.

If it doesn't work, there's probably something not configured properly in IIS.

Please, let us know how it goes.

Regards
---
Daniel Altamirano

Feb 10, 2012 at 3:53 PM

I tried that and I still get the same error.

Is there something in IIS I need to look for?

 

-Joe

Feb 10, 2012 at 4:44 PM

That worked, I had to completely uninstall IIS (Remove the Role) and re-add it back.  Then the app worked fine.

Thanks for your help

 

-Joe

Developer
Feb 10, 2012 at 5:18 PM

Excellent!

One question, so we can help other users that may face this problem: are you using Windows 7, or Windows 2008 R2? Did you reinstall anything else apart from the IIS role?

Thanks!
---
Daniel Altamirano

Feb 10, 2012 at 5:32 PM

Everything was on a Windows 2008 R2 Enterprise SP1 Server. 

What I did first was make sure the default site on port 80 was working.  I put a basic helloworld.html file there and tried to browse to it.  That wouldn't work so I knew something was wrong with IIS.  I completely removed the IIS role and rebooted the server then added the IIS role back rebooting again.  Then I tried the helloworld.html page to make sure IIS worked, which it did.  So I installed MySemanticSearch gain and it worked.

I can get some screen shots later of what my IIS role looks like, but it was the same as yours.

-Joe

Developer
Feb 10, 2012 at 5:38 PM

No need for those screenshots Joe, this description alone will help us write a more thorough answer for future reference.

Thanks a lot!

Best regards,
---
Daniel Altamirano