Won't install on RC0

Nov 22, 2011 at 2:05 PM

When I execute the Setup.cmd I get the following error:

"This Demo requires SQL Server Denali."

I have successfully installed SQL Server 2012 RC0.

Please advise.

Nov 22, 2011 at 2:21 PM

Hi JJanicik,

It's possible that the script that checks whether SQL Server 2012 is installed or not has been rendered obsolete with the new version.

A workaround would be to disable that check if you're certain that SQL Server 2012 is installed. Follow this procedure:

  1. Open the Dependencies.ps1 file, located at Setup/Tasks, in the MySemanticSearch Setup folder.
  2. Comment the lines regarding the SQL Server Denali dependency (using # at the beginning of each line).
  3. Save the script, close the editor, and run the Setup script once again.


Let me know if that works for you.

Daniel Altamirano

Nov 22, 2011 at 4:15 PM



I commented out the Denali check and the installation continued further.


However, I am not getting the following errors later in the installation routine.


Setup tasks for "My Semantic Search" application

Checking Dependency: IIS

Checking Dependency: NET4

Checking Dependency: SQL Denali

Checking Dependency: Silverlight

Creating web site...

Import-Module : The specified module 'WebAdministration' was not loaded because
 no valid module file was found in any module directory.
At C:\MySemanticSearch\Tasks\CreateSite.ps1:1 char:14
+ import-module <<<<  WebAdministration
    + CategoryInfo          : ResourceUnavailable: (WebAdministration:String)
   [Import-Module], FileNotFoundException
    + FullyQualifiedErrorId : Modules_ModuleNotFound,Microsoft.PowerShell.Comm

New-Item : A parameter cannot be found that matches parameter name 'bindings'.
At C:\MySemanticSearch\Tasks\CreateSite.ps1:5 char:49
+ New-Item 'IIS:\Sites\MySemanticSearch' -bindings <<<<  @{protocol="http";bind
ingInformation="*:7777:"} -physicalPath ($rootPath + "\MySemanticSearch")
    + CategoryInfo          : InvalidArgument: (:) [New-Item], ParameterBindin
    + FullyQualifiedErrorId : NamedParameterNotFound,Microsoft.PowerShell.Comm

Installing WCF Ria Service...

Import-Module : The specified module 'WebAdministration' was not loaded because
 no valid module file was found in any module directory.
At C:\MySemanticSearch\Tasks\InstallService.ps1:1 char:14
+ Import-Module <<<<  WebAdministration
    + CategoryInfo          : ResourceUnavailable: (WebAdministration:String)
   [Import-Module], FileNotFoundException
    + FullyQualifiedErrorId : Modules_ModuleNotFound,Microsoft.PowerShell.Comm

Get-Item : Cannot find drive. A drive with the name 'IIS' does not exist.
At C:\MySemanticSearch\Tasks\InstallService.ps1:3 char:21
+ $site_id = (Get-Item <<<<  "IIS:\sites\$website").ID
    + CategoryInfo          : ObjectNotFound: (IIS:String) [Get-Item], DriveNo
    + FullyQualifiedErrorId : DriveNotFound,Microsoft.PowerShell.Commands.GetI


I did run the PowerShell directions prior to running the install.

Thoughts on what is going wrong.

Thanks for your help.


Nov 22, 2011 at 4:54 PM

Hi Jim,

Did you check that you have all the prerequisites? Please, check them here: http://mysemanticsearch.codeplex.com/wikipage?title=Prerequisites

For IIS Prerequisites, check the answer to this other discussion: http://mysemanticsearch.codeplex.com/discussions/278082

Let me know if you have everything set, or if there's something missing in your environment.

Daniel Altamirano

Dec 9, 2011 at 2:34 AM


Did anyone ever get this working on RC0? I have it sucessfully installed and I just went through all of the prerequisites and verified that Semantic Search, etc. are installed. When I launch the Silverlight app and try to connect to my local SQL 2012 RC0 instance, I get:

Invoke operation 'CheckServerConnection' failed. [HttpWebRequest_WebException_RemoteServer]
Arguments: NotFound

Can anyone suggest anything else or do I need to roll back to a CTP3 install to get it to work?

Thanks for any help you can offer.

Dec 12, 2011 at 7:27 PM

We got the MySemanticSearch sample working on SQL Server 2012 RC0.

Based on our understanding there is a problem in the connection between the Silverlight app and the SQL Server 2012 instance. Could you check if you have the following correctly set?

  • Your firewall allows the MySemanticSearch sample to connect the SQL Server 2012 RC0 instance. To check if that's the problem, disable it and try to use the Silverlight app again.
  • The Windows user running MySemanticSearch has SQL Server Administrator permissions to connect to the SQL Server 2012 RC0 instance.
  • The network name of the SQL Server Instance is reachable from the machine where you're running MySemanticSearch.
  • All the prerequisites are installed. Please, check them here: http://mysemanticsearch.codeplex.com/wikipage?title=Prerequisites
  • IIS Prerequisites. For this you can check the answer to this other discussion: http://mysemanticsearch.codeplex.com/discussions/278082 

In addition, It ‘d be helpful if you could provide us information about your local environment, such as:

  • OS version
  • IIS version

I hope you find this helpful,

Daniel Altamirano

Dec 12, 2011 at 8:39 PM


Thanks for the reply.

I tried disabling Windows Firewall across the board and it didn't help. I still get the same message.

I'm running the Silverlight app under my account which has administrative rights. I also tried running it with elevated priviledges just to make sure.

Everything is on my local machine...SQL Server 2012 RC0, IIS 7, Windows 7 Enterprise. I've tried "localhost", my computer name (SQL Server Name) and "." in the connect to box. All get the same result.

I reviewed the prerequsites again and I think I have everything configured properly. I can do FILESTREAM, FileTable, Full Text and Semantic Search operations with T-SQL from SSMS.

Based on some searching on the error message I'm getting, it seems like the problem is between the Silverlight application and the web service.

Thanks again for any help you can offer.


Dec 16, 2011 at 7:13 AM

Having the same problem on RC0. I believe this error is related to authentication, not firewalls (disabling the firewall did not help) -- but sorry, I am not an IIS expert.

The codeplex application is installed on the same machine -- Server 2008 R2 -- where the RC0 is installed. I disabled the installation check for Denali, and went through the installation requirements before application installation. 

My errors:

Invoke operation 'CheckServerConnection' failed. [HttpWebRequest_WebException_RemoteServer]
Arguments: NotFound
Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=4.0.60831.0&File=System.Windows.dll&Key=HttpWebRequest_WebException_RemoteServer

I ran Fiddler http://www.fiddler2.com during the call and this trace program returned:

HTTP/1.1 401 Unauthorized
Server: Microsoft-IIS/7.5
X-Powered-By: ASP.NET
Date: Fri, 16 Dec 2011 00:00:00 GMT
Content-Length: 0



Dec 16, 2011 at 1:02 PM

Hi guys,

Next week we'll be working on this issue you reported, so you can expect more feedback then.

Thank you very much for your extra effort on sending us more information Mark. We'll do our best to find a solution for you both.

Daniel Altamirano

Dec 17, 2011 at 3:10 PM

As the folks above have commented and possibly related to the work item http://mysemanticsearch.codeplex.com/workitem/118, I too am having trouble using RC0. Windows 7 Enterprise, SP1 x64 + Microsoft SQL Server 2012 RC0 - 11.0.1750.32 (X64)

I was rather impatient so I pulled down the solution. I had grabbed the prerequisites, but the build failed for a number of missing references

  • Kit3D http://kit3d.codeplex.com/  
  • System.Windows.Interactivity (Comes from Expression Blend 3)
  • Silverlight_Developer.exe (Visual Studio hooked me up with the install automagically. File version 4.0.60831.0 Product Version 5.5.0031.0 Size 8.17MB)

For the first two, since I already had C:\MySemanticSearch\Resources\MySemanticSearch.xap, I made a copy of that file and renamed .xap to .zip and copied the two  DLLS into MySemanticSearch\Bin\Debug and recompiled and the solution was able to build.

Once I ran it, it connected to my instance (MACHINENAME\LOCALSQLB), correctly populated the Database and FileTable drop down lists before it blew chunks.

Line 1352 of MySemanticSearch.ViewModel.MainPageViewModel is what is throwing an unhandled exception

this.SelectedSearchDocumentProperty = this.SearchDocumentProperties.Last();

If I wrap the above in a try/catch and simply swallow the exception, it seems to work fine.

Perhaps related, I believe my FT index/semantic search stuff is not right as semantickeyphrasetable is empty for the single FileTable I have defined.

Dec 18, 2011 at 6:36 PM

+1 on the issue described by MarkTab.  Looking forward to working with this on RC0.


Dec 22, 2011 at 10:17 PM
Edited Dec 22, 2011 at 10:43 PM

Hi guys,

We built a new environment from scratch to test the application with SQL Server 2012 RC0, and it worked fine. We were unable to reproduce the errors you described.

Some tips that may be helpful to determine what's causing the problem on your side:

  • Whether you have Windows 7 or Windows Server 2008 R2, check that the following features are installed:
  • When you install SQL Server 2012 RC0, you should enable FILESTREAM:
  • Be sure to install, attach and register the Semantic Language Statistics Database (required for semantic search). You can find more information about this here.
  • You should be able to see the same files at the same paths, as you can see in the screenshots below (C:\inetpub\wwwroot\MySemanticSearch)
  • DLL Version for the files you can see in the bin folder above, is 11.0.1422.17
  • Also, when you connect to the SQL Server 2012 instance, check the alias you're using is valid. To do this, you can open SQL Server Management Studio and try to connect to the Database Engine using that alias. If it doesn't work, it won't work on MySemanticSearch. If it does, it will work on MySemanticSearch.

Please, check those things and let us know if anything there helps to shed some light on this issue.

Best regards,
Daniel Altamirano

Feb 11, 2012 at 7:01 PM
Edited Feb 11, 2012 at 7:37 PM

Hi Daniel

Thanks for your December 22 response -- this post has a solution.

At the time, I was enjoying a holiday break in California (where I grew up), and got to see some new parts of the state. 

Pardon the graphics: this post started as my response to yours (for debugging), but based on responses from February 10, 2012, I was able (today) to find exactly what was different in my setup.  The solution (in my case) is to install Windows Authentication as part of IIS.  As with all parts of Windows Server 2008 R2, servers are set up different ways.  In my case, I am not explicitly using IIS for other uses, so I believe the reason other people had seen this same connection error is that we had installed IIS under default-type settings, but were not actively using it.

I will be including my corresponding screen shots based on your earlier message.  I knew I was using Windows Authentication to connect to SQL Server, but was unaware that it was not included in IIS.  As you recall from my initial message, I believed the issue was related to IIS and authentication, but I did not know how to proceed.  Given that this demo is for SQL Server, my debugging energy was focused on the new pieces of SQL Server 2012 instead of directed at IIS.  Apparently, others were of the same mindset.

Different compared with last time is that this response is based on the January 17, 2012 build.  I was motivated to make this sample work since I will be using it for some demos (I have been getting more speaking opportunities since entering the Microsoft MVP program).  FYI -- I happened to see a past demo of this software, and they had included a paper I wrote titled Why Use Microsoft Data Mining -- I had to do a double take when I saw that prevous demo.

My OS is Windows Server 2008 R2, and Server Manager provides an enumeration of installed software and services.


 In my case, I had not enabled Filestream during installation, but Filestream can be subsequently intialized by using Configuration Manager and also running a EXEC command (the latter I believe is equivalent to changing the properties on the server and restarting).


Reference: How to Enable Filestream (for SQL Server 2008 R2, but still OK for SQL Server 2012 RC0): http://msdn.microsoft.com/en-us/library/cc645923.aspx

I had previously installed the Semantic DB, and I am doing this demo using the "Administrator" account:


The files appear to be complete -- this build has the version of 11.0.1750.32

 I already demonstrated in the above SSMS picture that I am able to connect to the database with this account.

Now, more on the Silverlight.  First, here is the response I see:




I believed the issue had something to do with IIS and authentication.  Reading the Incomplete Install? No Desktop Shortcut discussion, I saw the screenshot from IIS based on Windows Authentication. These days, that method is the standard way to connect to SQL Server.  I noticed that this options was NOT available on my IIS this time, and to test my theory, I made one change:  I added Windows Authentication.  Other forms like Digest and Basic were not included in my installation.  Once I made this change, the Silverlight application connects. 

I have several abstracts submitted for upcoming SQL Saturday events, and hope to use this demo as part of these potential presentations.



Mark Tabladillo
Microsoft MVP
Blog:  http://marktab.net/datamining
Twitter @marktabnet

Feb 12, 2012 at 1:53 AM

Hi Mark!

Hope you enjoyed those holidays in California! :)

I'm really glad that you were able to pin the problem down! Thank you so much for all the effort you put in explaining all of this! It's invaluable information for other users.

Please, let us know if there's some video or other material from those events. We'd love to see those presentations using this application.

Best regards,
Daniel Altamirano

Feb 16, 2012 at 7:48 PM

Hi Daniel

I will be presenting semantic search at the Atlanta SQL Saturday:  http://www.marktab.net/datamining/index.php/2012/02/15/presenting-sql-saturday-111-atlanta-april-14/

I intend to include this project.

If I have other presentations or make videos, I will post links to the discussion.


Mark Tabladillo
Microsoft MVP
Atlanta GA

blog http://www.marktab.net
Twitter @marktabnet

Mar 22, 2012 at 10:11 PM
Edited Mar 23, 2012 at 12:07 AM

I've got everything setup and all of the screens match what is shown in the posts above (mostly, i'm testing on Windows 7 Ultimate), but the Configure SQL Server Instance screen hangs when I enter either localhost or my instance name.  It just says ..Please Wait... and never connects. 

I'm using SQL 2012 Developer version 11.0.2100.60.  Windows Authentication is setup on IIS7 and all the components installed fine.  The desktop shortcut was not installed, but otherwise the install process was smooth.


I found the fix on another thread.  I had Silverlight installed on C: and MySemanticSearch on D:.  After uninstalling and moving the MySemanticSearch folder to the root of C: (it won't accept spaces in the path), the reinstall worked and the desktop icon appeared.  After that it connected to SQL and all is well.

Apr 3, 2012 at 4:54 PM

Awesome! Glad you got this working.

We'll add those tips to the prerequisites section. Thank you very much!

Best regards
Daniel Altamirano